I cant seem to get my collada file to work.

Software: Prefab3D

Eskalior, Newbie
Posted: 21 December 2014 01:13 AM   Total Posts: 1

Greetings.

I created a little Dummy with a very happy walking animation, because I later want to cut him in two with a chainsaw in my Away3D application.

I wanted to manage the import like in the Polar Bear example, so I wanted to create the mesh and animation and turn it to AWD2 in Prefab3D.

It tourned out to be slightly more difficult, as I tried to get the collada file out of blender to work. After a lot of hours, many “Collada Export Do’s and Dont’s” Tutorials and a lone tear running down my cheek, I finally hope for an answer in this forum.

First, here is a .rar package with the .blend file and some of the rather unfunctional results:
ht*tp*://*fbe*.am*/*vfG (delete the * ‘s)

What I tried:
I tried all the “solutions” of those export tutorials.
For example moving everything to (0,0,0), baking the animation and adding keyframes for every frame, deselecting all actions and exporting in a lot of different ways.

The result was always the same. Here are the problems Prefab3D showed me:
1. there are always 2 States, doesnt matter how many actions I have created.
2. both States are named “null”
3. Sometimes the states have the correct count of Nodes, sometimes not.
4. Playing the animation doesnt do anything. The Mesh doesnt move.

In AwayBuilder, as soon as I try to play the animation, I get a lot of errors.

And here comes the weird part:
I downloaded a collada file from the internet and tried it. Both the animation and the mesh worked fine in Prefab3D. So I imported it in blender and exported it again. Again, the animation worked fine, there was just a little problem with the mesh-angle. But nothing special. (the states still were named “null” in both cases)

I compared all properties of the downloaded collada with the ones of my Dummy, in my point of view everything was the same but still no result.

Then I created a simple cube with only one bone in blender and exported it. The animation worked. Well, the states were named null and there was the angle problem again, but it worked.. I did the same as with my Dummy, he doesnt work and the cube works. One may think “maybe it’s the bone/poly count”. But no, the collada from the internet had far more bones and polys.

As a last attempt I tried to export it as md5, but the plug-in always threw errors.

I dont know any other solution, but I’d like to stick with blender.

If anyone manages to get my little Dummy to work with his animation in Prefab3D/Away3D, he will be my messias for one day.

Thanks.

   

Avatar
Fabrice Closier, Administrator
Posted: 21 December 2014 09:51 PM   Total Posts: 1260   [ # 1 ]

Prefab also allows you to edit the animation via vertex animation editor in case of…
for animation the public version of Prefab can load only md2, own format pfb for vertex animations and loads skeleton animations from awd, pfb, md5 and Collada 1.4.x (if you use 1.5, chances are it will do nothing as I’ve decided skip support for this “variable as the wind” format).

The “null” state names case may in your version also caused by internal bug in the app that occured when two states were having same name. Current version has a fix and replaces automatically similar names with stateid+increase. It doesn’t affect the functionality, but may lead to problems once loaded back in away3d.

You can send me your animation offline so I could take a look when I’ll have a moment… send it to fabrice3d at gmail dot com

   
   

X

Away3D Forum

Member Login

Username

Password

Remember_me



X