Away3D Forum 2017-12-21T14:31:18Z Copyright (c) 2017 ExpressionEngine tag:away3d.com,2017:12:21 I have an Issue with prefabe3D and I seek help. tag:away3d.com,2017:forum/viewthread/.6280 2017-12-21T14:30:24Z 2017-12-21T14:31:18Z O_MEGA Hi, I imported a 3D file (made and textured in blender) into prefab3D, then I tried to export the file as either AWD1 or AWD2. NO AWD FILE WAS CREATED IN THE SPECIFIED DESTINATION! I don’t know the reason. I hope somebody will help me.

]]>
Md2 strip Material tag:away3d.com,2016:forum/viewthread/.6156 2016-08-26T10:31:30Z 0 Tempy111 Okay, got a Md2 I made, it’s fine. I used it with Away3d 3.6 but anyway

I won’t load in Away3D 4. the problem seams to be a dependency for a material. I load the Md2 into Prefab and yep, it seams to be looking for a material. Now, I want to STRIP that material, so it’s the same, say the example files md2. the Model when in Away3d will have one of two materials depending. I try to export it in Prefab as a md2 without saving dependency but, it doesn’t strip the need from one in the code and I can’t figure out where (if anywhere) there is something that’ll let me remove the material.

Any clues?

]]>
about md2 tag:away3d.com,2016:forum/viewthread/.6130 2016-07-22T05:05:48Z 0 mkfui sir, i export md2 file from 3ds max, fragmotion or prefab3d, when i import it into prefab3d, mesh & animation sequence look ok, but never appear when i using away3d, why ? no error message in debug log

]]>
export vertex animation to as3 tag:away3d.com,2016:forum/viewthread/.6119 2016-07-09T08:27:41Z 0 mkfui i try to export my md2 vertex animation to as3, but it became very difficult to control, animator only play one animation

1) how can i play more than 1 animation by modifying those meshanimdata?

2) can i trigger that animation by adding button/listener in prefabproject.as ?  just like md2 animation, or shall i add those button/listener in animated mesh as file (animated character file) ?

3)what this mean ? “_animators[_animators.length-1].play(“default”);”, why animators.length must minus by 1 ?

4)how can i animate texture in meshdata.as ?

can anyone demonstrate it for me ?

]]>
configuration & customization for cadet3d editor tag:away3d.com,2016:forum/viewthread/.6120 2016-07-09T08:30:40Z 0 mkfui i am beginner for away3d, therefore not that understand about tutorial like “Cadet Engine Getting Set Up, Cadet Editor Editor Extensions”, i have made a few examples successfully, (build swf files) like behaviour & bunny mark, but not in planet & robot by using flashdev (but not by flash builder, first time i use it, i try to follow instruction in Cadet Engine Getting Set Up, but fail)

error massage like this appear, what this mean? i have to embed those cdt3d files ? any modified example ? D:\burn 9\CoreApp-as-0.4.2-beta\CoreApp-as-0.4.2-beta\src\core\app\util\swfClassExplorer\data\Traits.as(13): col: 15 Warning: No constructor function was specified for class Traits. D:\cadet\CoreApp-as-0.4.2-beta\CoreApp-as-0.4.2-beta\src\core\app\managers\fileSystemProviders\local\FileSystemUtil.as(39): col: 62 Error: Type was not found or was not a compile-time constant: File. public static function fileToURI( file:File, rootDirectory:File, fileSystemProviderID:String ):URI

can anyone send me the cadet3d editor together with custom extension (exported swf) & customised config.xml ? (since i cant’ make it by myself) mkfuiy at gmail dot com

according to instruction, there are no cadet3d editor air file to download, i have to download cadet2d editor air file & customize it by myself ? am i right ?

how about core editor & cadet editor tutorial in github “https://github.com/CadetEditor/CadetEditor-as/wiki”, open sources for customise extension ?

]]>
How do you select an exported as3 Prefab2 object with the mouse? tag:away3d.com,2015:forum/viewthread/.6003 2015-12-20T01:21:33Z 0 Bill7745 Hi I’m trying to select an object with the mouse that I exported as an AS3 class from Prefab2. It’s a soldier that I’m trying to select:

_soldier = new Soldier();
  _soldier.scale(.10);
  _soldier.x = 0;
  _soldier.y = 25;
  _soldier.z = -100;
 
  _soldier.mouseEnabled = true;
  _soldier.addEventListener(MouseEvent3D.MOUSE_DOWN, _soldierOnMouseDown);
  scene.addChild(_soldier);

but it doesn’t work. Any idea how I could select it with the mouse so I can move it around.

]]>
Fabrice? tag:away3d.com,2016:forum/viewthread/.6052 2016-03-13T16:19:08Z 0 alpoman Hello, I noticed on prefab 1, there are buttons to render raytraced images and the ability to save - this is great!!!  is there a method to do this in version 2?  thanks for any help, and I do really appreciate your great work on this project!

andy

]]>
casted shadows possible tag:away3d.com,2016:forum/viewthread/.6051 2016-03-12T01:35:31Z 0 alpoman Hello, this seems really cool but I’m still trying to learn it -
Is there a way to bake shadows cast on mesh?  I see the lighting is awesome, but no shadows.  Am I missing something, cant find a method for hardshadow or anything, and not sure this is for that at all.  Also, when I export my awd 2 file, the light effects dont appear on my model in awaybuilder.  thanks in advance, I love this so far!!!

andy

]]>
I cant seem to get my collada file to work. tag:away3d.com,2014:forum/viewthread/.5742 2014-12-21T01:13:37Z 2014-12-21T01:15:01Z Eskalior Greetings.

I created a little Dummy with a very happy walking animation, because I later want to cut him in two with a chainsaw in my Away3D application.

I wanted to manage the import like in the Polar Bear example, so I wanted to create the mesh and animation and turn it to AWD2 in Prefab3D.

It tourned out to be slightly more difficult, as I tried to get the collada file out of blender to work. After a lot of hours, many “Collada Export Do’s and Dont’s” Tutorials and a lone tear running down my cheek, I finally hope for an answer in this forum.

First, here is a .rar package with the .blend file and some of the rather unfunctional results:
ht*tp*://*fbe*.am*/*vfG (delete the * ‘s)

What I tried:
I tried all the “solutions” of those export tutorials.
For example moving everything to (0,0,0), baking the animation and adding keyframes for every frame, deselecting all actions and exporting in a lot of different ways.

The result was always the same. Here are the problems Prefab3D showed me:
1. there are always 2 States, doesnt matter how many actions I have created.
2. both States are named “null”
3. Sometimes the states have the correct count of Nodes, sometimes not.
4. Playing the animation doesnt do anything. The Mesh doesnt move.

In AwayBuilder, as soon as I try to play the animation, I get a lot of errors.

And here comes the weird part:
I downloaded a collada file from the internet and tried it. Both the animation and the mesh worked fine in Prefab3D. So I imported it in blender and exported it again. Again, the animation worked fine, there was just a little problem with the mesh-angle. But nothing special. (the states still were named “null” in both cases)

I compared all properties of the downloaded collada with the ones of my Dummy, in my point of view everything was the same but still no result.

Then I created a simple cube with only one bone in blender and exported it. The animation worked. Well, the states were named null and there was the angle problem again, but it worked.. I did the same as with my Dummy, he doesnt work and the cube works. One may think “maybe it’s the bone/poly count”. But no, the collada from the internet had far more bones and polys.

As a last attempt I tried to export it as md5, but the plug-in always threw errors.

I dont know any other solution, but I’d like to stick with blender.

If anyone manages to get my little Dummy to work with his animation in Prefab3D/Away3D, he will be my messias for one day.

Thanks.

]]>
PANICK tag:away3d.com,2014:forum/viewthread/.5692 2014-10-19T20:23:16Z 0 drbii Installing new system and I can’t get the download links to the Prefab to work.  Link to Prefab site does not work!

What is going on.  I need [my] prefab!

Thanks!
Dan

]]>