IPA setup creation FAILED

Software: Away3D 4.x

62316e, Newbie
Posted: 15 June 2013 07:02 PM   Total Posts: 25

I’m trying to build AwayPhysics for iOS. But when i compiling release/ad-hoc or even (slow-debug) under FD:

Exception in thread “main” java.lang.OutOfMemoryError: Java heap space
at java.lang.Integer.valueOf(Unknown Source)
at adobe.abc.GlobalOptimizer.merge(GlobalOptimizer.java:9985)
at adobe.abc.GlobalOptimizer$InputAbc.readCode(GlobalOptimizer.java:1265
at adobe.abc.GlobalOptimizer$InputAbc.readBody(GlobalOptimizer.java:685)

at adobe.abc.GlobalOptimizer$InputAbc.readBodies(GlobalOptimizer.java:40
at adobe.abc.LLVMEmitter.generateBitcode(LLVMEmitter.java:331)
at com.adobe.air.ipa.AOTCompiler.convertAbcToLlvmBitcodeImpl(AOTCompiler
at com.adobe.air.ipa.BitcodeGenerator.main(BitcodeGenerator.java:104)
Compilation failed while executing : ADT

I’ve tested with: Adobe Air 3.4 (Flex SDK) Adobe Air 3.5 (Flex SDK) Adobe Air 3.6 (Flex SDK) Adobe Air 3.7 (Flex SDK) Adobe Air 3.8 Beta (Flex SDK)

Adobe Air 3.7 (ASCSDK) Adobe Air 3.8 (ASCSDK)

I’ve also tried “-optimize=false” nothing helps.

Only fast-interpreter mode works which is really slow!

Steps to reproduce:

  Download AwayPhysics (Bullet physics ontop of flascc) https://github.com/away3d/awayphysics-core-fp11/tree/dev or Oimophysics
  Build any sample or just include AWPDynamicWorld


After increasing heap memory size to -Xms1024m -Xmx1524m:

Exception in thread “main” java.lang.OutOfMemoryError: Java heap space
at java.util.HashSet.<init>(Unknown Source)
at adobe.abc.Algorithms$SetMap.get(Algorithms.java:226)
at adobe.abc.Algorithms.addUses(Algorithms.java:165)
at adobe.abc.Algorithms.findUses(Algorithms.java:187)
at adobe.abc.GlobalOptimizer.sccp(GlobalOptimizer.java:4731)
at adobe.abc.GlobalOptimizer.optimize(GlobalOptimizer.java:3615)
at adobe.abc.GlobalOptimizer.optimize(GlobalOptimizer.java:2309)
at adobe.abc.LLVMEmitter.optimizeABCs(LLVMEmitter.java:532)
at adobe.abc.LLVMEmitter.generateBitcode(LLVMEmitter.java:341)
at com.adobe.air.ipa.AOTCompiler.convertAbcToLlvmBitcodeImpl(AOTCompiler
at com.adobe.air.ipa.BitcodeGenerator.main(Bitcod

  Compilation failed while executing : ADT

Please do not advice me increasing memory to 1024 and etc. its not related to memory amount. As i said i have 16gb ram, at leat 14 free..

Java uses as many as i set and still crashes with same error.


Fabrice Closier, Administrator
Posted: 15 June 2013 07:56 PM   Total Posts: 1265   [ # 1 ]

Do you embed one or more models?


62316e, Newbie
Posted: 15 June 2013 08:35 PM   Total Posts: 25   [ # 2 ]

I dont embed anything.
Clean sample from git hub dev branch of away physics.


Amerd, Newbie
Posted: 15 September 2013 07:26 AM   Total Posts: 2   [ # 3 ]


After alot of search I found that the issue is happen because of flascc. if you try to export a release build with the old version of awayphysics this will solve the export issue, but unfortantly the old version is not working fine with me using away3d 4.1 something wrong happen to the camera position after the physics world start rendering. it is working fine with the flascc version on computer but the issue of export a release build still there :(


62316e, Newbie
Posted: 16 September 2013 08:30 PM   Total Posts: 25   [ # 4 ]

Guys please help fix this bug.
Vote here, write comments, rage!


koblongata, Newbie
Posted: 24 September 2013 07:56 PM   Total Posts: 28   [ # 5 ]

Remove 32bit java and install the 64bit version works for me, the projects compiles to adhoc ipa under flashdevelop (takes really really really long time though). And this is pretty fast!

Flash Pro CC still no go, got java GC overhead error.

I wonder how the new awayphysics compares to the bullet.ane (ios only), because I still cannot get that to compile
the author showed a comparison between awayphysics and bullet.ane, but it seems that the test was done with older version not the current flacc one.


Hec, Newbie
Posted: 09 March 2014 01:29 PM   Total Posts: 20   [ # 6 ]

Is there a solution for that problem now.
AwayPhysic FlashCC airsdk4.0.1628, Java8 (64), still not packaging ipa,
OutofMemory GC



Away3D Forum

Member Login