Texture with alpha, Z order error

Software: Away3D 4.x

Pengeszikra, Newbie
Posted: 05 February 2013 10:18 PM   Total Posts: 2

I make 3d scene with blender. Export obj format ( work well ).
When i will try make some bush and tree with transparent png texture

mesh.material.alphaBlending true
.material.alphaThreshold 0.5 

After all is looks fine I faced Z-order problem:


How can i solve this problem without z-sorting tree manualy by angle of view?


kingston250, Newbie
Posted: 16 March 2013 01:29 PM   Total Posts: 11   [ # 1 ]

You create a good one. but i don’t know how to solve it.


Łukasz Łazarecki, Newbie
Posted: 08 November 2013 08:39 PM   Total Posts: 3   [ # 2 ]

Try using Object3D’s zOffset property and set it to a high negative value.


theMightyAtom, Sr. Member
Posted: 09 November 2013 08:26 AM   Total Posts: 669   [ # 3 ]

Have you tried turning off alphaBlending?


Łukasz Łazarecki, Newbie
Posted: 09 November 2013 11:37 AM   Total Posts: 3   [ # 4 ]

Yes, and without alphaBlending it works perfectly. But I need alpha blending to be on, and no, alphaThreshold is not an option, because it looks awful.

But the zOffset is probably the way to go for most of the people. You can probably even calculate it each frame to have more control over z-order of objects displayed. For me, setting it high enough was a sufficient solution.

Nevertheless, I’d love to see this z-sorting bug being fixed. Do other frameworks have such problems? Do Unity3D users need to do this kind of things also? I doubt it.



Away3D Forum

Member Login