Away3D Forum 2017-05-08T10:37:45Z Copyright (c) 2017 ExpressionEngine,2017:04:26 Problem with stage3D and away3D,2017:forum/viewthread/.6218 2017-04-26T07:19:12Z 2017-05-08T10:37:45Z JohnAdam Ok that is so strange it make like 3 hour i try to figure this out. First… everything was working correctly so i don’t know what i change or if i updated to new code for starling or away3d and i dont think so.

I use the standard code to create a stage3DProxy

   * will start the engine
public function StartUpEngine():void {
// Define a new Stage3DManager for the Stage3D objects
stage3DManager Stage3DManager.getInstance(stage);
// Create a new Stage3D proxy to contain the separate views
stage3DProxy stage3DManager.getFreeStage3DProxy();
stage3DProxy.antiAlias 8;
stage3DProxy.color 0xff0000;
private function onContextCreated(event Stage3DEvent) : void {
stage3DProxy.width stage.fullScreenWidth;
stage3DProxy.height stage.fullScreenHeight;
//Init everything

all was working.. now… away3D is working but i can’t get starling to render… it’s clearly there when i trace it.

I do have a enter_frame event that do a nextFrame()

private function InitListeners():void {
private function onEnterFrame(e:Event):void {
//render starling and away3d

all pretty standard and it worked!

if i just disable the proxy and do a normal starling instance it’s working.

i swear all was working yesterday i just don’t get it. i trie dto just disable the away3D and starling still not render. it’s like the proxy wasn’t working but IT WAS working before…

Anyone got a hints ? it make 3 hours i’m searching and i’ve tested every options.

read more: toyota fortuner 2017, hyundai tera 190, mitsubishi attrage 2017

Away3D questions,2017:forum/viewthread/.6212 2017-04-12T09:26:06Z 2017-05-03T10:14:50Z JohnAdam Hi guys, I am starting to work with Away3D and I will have few questions in an upcoming days for those who already worked with it.

Question: Is it possible to decrease the number of polygons on the external model without editing the model in some 3D graphic software? I have bought human model made in 3D Max but it is so complex

Tags: gia toyota fortuner 2017, gia mitsubishi new outlander 2017

File not found: file:/C:/Program Files (x86)/Adobe Gaming SDK 1.4/Samples - Copy/Away3D/Invawayders/bin-debug/Main.html,2016:forum/viewthread/.6129 2016-07-18T17:02:25Z 0 tekielee When I run the sample program invawaders in flash builder, I got the following error. Please help. Thanks.

File not found: file:/C:/Program Files (x86)/Adobe Gaming SDK 1.4/Samples - Copy/Away3D/Invawayders/bin-debug/Main.html

Artifacts when change properties of CylinderGeometry?,2016:forum/viewthread/.6096 2016-05-17T21:55:52Z 0 ralphB If I create a cylinder geometry by doing
var cyl:CylinderGeometery = new cyl:CylinderGeometery()
cyl.topRadius = 5; // Or any other property change

Then I see the correct shape, but I also see an artifact that looks like a piece of the side of the original cylinder. 

But if I pass in all the properties when I create the cylinder, e.g.
var cyl:CylinderGeometery = new cyl:CylinderGeometery(5, etc)

then it renders correctly.  Is this a bug, or do I need to do something to clear the geometry before or after I change its properties?

3d renders,2016:forum/viewthread/.6054 2016-03-14T17:46:17Z 2016-09-22T18:09:48Z emily “Hi guys,
I have a question. Do you make 3d renders of your projects in-house or use outsource visualization company?”

OrthographicLens.unproject,2015:forum/viewthread/.5839 2015-04-13T08:05:04Z 2015-04-13T08:06:14Z movieclip

51   override public function unproject(...):Vector3D
56 v.x = nX + translation.x;
57 v.y = nX + translation.y; //should be v.y = -nY + translation.y;
58 v.z = sZ;
59 v.w = 1;


Strange behavior when calling consecutive transform within an event,2014:forum/viewthread/.5422 2014-04-10T13:58:34Z 2014-04-10T14:00:38Z rdoi Basically, you can’t access a sceneTtransform and set an unrelated object.transform within an event…?

private function initCameraListener() : void {

private function onCameraChange(event Object3DEvent) : void {
const camera Camera3D = ( as Camera3D);
obj Object3D = new Object3D();

// ********************************************************
   // Does nothing, purposely. Just to force a getter call.

// This affects the camera hover!
   // Comment out this line, or the above one to get the expected result
obj.transform = new Matrix3D();
// ********************************************************
// // // // // // ////////////////////////////////////////// 

I’ve attached a full code for an example of this strange behaviour.

I speculate that it is caused by parallel access of statics consts like Matrix3DUtils.RAW_DATA_CONTAINER and others.

I understand that it optimizes the memory access avoiding constant memory allocation, but it may cause some weird problems when running in asynch codes.


Possible Memory Leak in Away3D OpenFL in removeChild() method,2015:forum/viewthread/.5810 2015-03-08T02:01:49Z 0 abpyles I have already made a post on GitHub about this issue here. This post is just to submit some code demonstrating the issue I am experiencing and to see if anyone knows what I am doing wrong, or if this is really a memory leak in Away3D.

DelaunayMesh - BUG,2012:forum/viewthread/.2791 2012-07-13T00:33:25Z 0 yyovchev I am playing with Delaunay extrusion and it is not drawing my mesh correctly. I tried same coordinates with Linear Extrude and it works fine. Here is example

var vec= new Vector.<Vector3D>;
vec.push(new Vector3D(4,0,-534.6));
vec.push(new Vector3D(1338.4,0,-534.6));
vec.push(new Vector3D(1338.4,0,-4));
vec.push(new Vector3D(914.4,0,-4));
vec.push(new Vector3D(914.4,0,-170.6));
vec.push(new Vector3D(4,0,-170.6));

plane= new DelaunayMesh(matvecDelaunayMesh.PLANE_XZfalse,falsetrue ); 

I hope this is easy to resolve.

Screenshot does not work on multiply views,2015:forum/viewthread/.5769 2015-01-28T01:45:07Z 0 62316e Hi,

The problem is shat queueSnapshot does not work on multiply views and the reason is the code in

if (!_shareContext{
if (_snapshotRequired && _snapshotBitmapData{
_snapshotRequired false;

Any workaround?