Prefab Animated AWD2 to Away3d 4 AWD2 parser

Software: Prefab3D

paullaster, Newbie
Posted: 06 December 2012 11:54 AM   Total Posts: 20

I have a model that exports and loads in and out of prefab just fine.  Great work with prefab by the way.  When I try to load the same model into Away3d 4 using the AssetLoader.  The geometry is corrupted.  Has anyone else experienced this?

I have included the model.


Fabrice Closier, Administrator
Posted: 06 December 2012 12:13 PM   Total Posts: 1265   [ # 1 ]

What is your Away3D 4 version? Prefab uses exact same parser as Away 4.0.9. Also, in what way your geomety is corrupted? (haven’t tested your model yet)


paullaster, Newbie
Posted: 06 December 2012 12:14 PM   Total Posts: 20   [ # 2 ]

Thank for the prompt reply.  I was thinking the same thing too,  that you would be using the same parser.  Prefab is the Away3d engine?

I was using 4.0 then I moved to 4.1 thinking maybe you did the same.  I will try back again with 4.09.

Let me add that non animated AWD2 to Away3d 4 models work just fine. 



paullaster, Newbie
Posted: 06 December 2012 03:09 PM   Total Posts: 20   [ # 3 ]

Ok. so i tested it in the previous version of away3d 4 and I still get the same visual error with the geometry.

It does parse and load in the test without error.  but drawing the geometry is incorrect.  I am going from MD5Mesh and Animation to Prefab to AWD2.

It is odd that i can export the model from Prefab and then import that same model back into Prefab with no error.  When it is using the same parser.



paullaster, Newbie
Posted: 07 December 2012 12:28 AM   Total Posts: 20   [ # 4 ]

I figure that it has something to do with the skeleton or joints when I convert a MD5 model to Prefab to Away3D.  All other models have worked fine.  I tested this process on the MD5 hellknight and a MD5 model we made.


Fabrice Closier, Administrator
Posted: 07 December 2012 02:29 PM   Total Posts: 1265   [ # 5 ]

Ok, we did some tests, and your awd2 dino loads/play just fine.

make sure you set the propper jointspervertex value in constructor.
skeletonAnimationSet = new SkeletonAnimationSet(5);


paullaster, Newbie
Posted: 07 December 2012 05:01 PM   Total Posts: 20   [ # 6 ]

Thank thank thank you.  It works and your help is much appreciated!  I thought it was something like that and I moved the number down but did not think to move the number up from 4!  The artist swore it had a max of 3 per vert.



Away3D Forum

Member Login