Import .3ds wiht 2.131

Software: Prefab3D

Manuel L., Member
Posted: 19 November 2012 01:45 PM   Total Posts: 99

hey, after updating to 2.131 now my 3ds-imports are broken. all objects have wrong values in poisiton, rotation etc.
i tried with excactly the same model, that work with 2.130.

any ideas?

   

Avatar
Fabrice Closier, Administrator
Posted: 19 November 2012 02:29 PM   Total Posts: 1260   [ # 1 ]

I’m in middle of an update for the 3ds parser. The 2.130 parser is faulty and matrices are inverted. Even if the displayed objects are looking correct, try move them/rotate around and you’ll see how weird it will go… Prefab update hold some update but obviously it doesn’t do it all right. Can you send me your 3ds so I can check what is going wrong and fix asap please? Send them to fabrice3d at gmail dot com. oh and please add a snapshot with them too, so I’ll have a visual ref as well.

 

   

Manuel L., Member
Posted: 19 November 2012 03:09 PM   Total Posts: 99   [ # 2 ]

okay, thank you ... done

 

   

Jeds, Newbie
Posted: 23 November 2012 04:37 AM   Total Posts: 5   [ # 3 ]

experiencing the same Fab, here is the sample screenshot + the related 3DS file for your reference.

the 2nd image: LB02grd.jpg is the texture file for the 3DS

Thanks and More Power

 

Image Attachments
3ds-bug.jpgLB02grd.jpg
File Attachments
LevelB2_v03_03.3DS  (File Size: 433KB - Downloads: 0)
   

Avatar
Fabrice Closier, Administrator
Posted: 23 November 2012 09:52 AM   Total Posts: 1260   [ # 4 ]

Can you please send it to me with the above email. Download fails for some reason. Thx.

 

   

Manuel L., Member
Posted: 26 November 2012 01:32 PM   Total Posts: 99   [ # 5 ]

did you get my files, fabrice?
i sent it to you last week.

anything new? i want to use the alpha release of away, but i can only if this bug is fixed. or do you have a workaround so far?

 

   

Avatar
Fabrice Closier, Administrator
Posted: 26 November 2012 02:09 PM   Total Posts: 1260   [ # 6 ]

did you get my files, fabrice?
Yes I did. Thank you.

Do you have a workaround so far?
Use another format such as obj or awd directly exported from your editor.

Anything new?
There are several things that needs to be added to the next update.
3ds is just one of them.
You’ll be prompted when an update is available.

 

   

SearchingSoul, Newbie
Posted: 30 November 2012 10:50 AM   Total Posts: 5   [ # 7 ]

hi,

i have also problems importing Objects. They re not 3ds related but to this version (at least i recognize it now):
There seem to be Smoothing Splits on UV borders.
First i thought it might be my model - but i think i could exclude every external problem through this test:
I imported the
POLARBEAR.AWD
from the current downladable samples. Added a texture and Set up a directional Light influencing with a Lightpicker. Specular Shading across the UV borders is alright (no hard edge).
Now i export this Model from Prefab as awd,obj and ac and reimport all of them seperatly into a fresh Prefab Session.
The Re-imported AWD looks fine.
The Re-imported obj looks unwelded. After a Prefab-weld the Specular Shading doesnt look right at UV Borders.
The Re-imported ac doesnt have right Specular Shading at UV Borders.

I attached all three exported Objects from Prefab (named directexport) aswell as the original AWD i used.

 

 

Image Attachments
polarbut_wrongSpec.JPGpolarbut_rightSpec.JPG
File Attachments
Specularshading.zip  (File Size: 557KB - Downloads: 359)
   

Avatar
Fabrice Closier, Administrator
Posted: 16 January 2013 09:33 PM   Total Posts: 1260   [ # 8 ]

I was really busy on update 2.135 and haven’t looked at your files yet. I will asap.

 

   
   

X

Away3D Forum

Member Login

Username

Password

Remember_me



X