Away3D Forum Away3D Forum en Copyright 2014 2014-02-26T23:56:27+00:00 Renaming of assets is buggy <p>It seems that renaming assets in hierarchy tab is quite buggy and unpredictable. Changing the name of an asset changes the name of all the assets in scene!</p> 2013-03-09T22:05:17+00:00 Prefab3D import .DAE without animation <p>Hi guys,<br /> i have a simple rotating cube from maya2012 exported with openCollada, if i open it inside prefab3d load only the mesh and the process log window says:<br /> Try parse file with extension: .dae<br /> url [file:///D:/maya/test/assets/cube.dae]</p> <p>Loaded and parsed dae file<br /> url [file:///D:/maya/test/assets/cube.dae]<br /> object added to scene<br /> Clearing anim data cache if any</p> <p>The mesh and animation is loaded well inside Flare3D IDE, the collada version is 1.4.1.<br /> I’ve read this topic:<br /> <a href=""></a><br /> and Fabrice say:<br /> If no errors, &lt;1.4.1, mesh only display, then the animation is not fully defined into the dae.<br /> Any ideas?<br /> Thanks!</p> 2013-05-18T18:22:29+00:00 3ds import wrong values <p>hey fabrice, when importing 3ds into the latest prefab it still has the wrong values. the model shows up fine, but the values are wrong. position of all meshes say 0, 0, 0. same with rotation.<br /> for me these values are not important, but it seems to be buggy.<br /> important for me are the rotation angles. they arent imported correctly, too.<br /> so when i rotate my meshes they dont rotate as they should do ^^</p> <p>best regards manu</p> 2013-04-10T08:06:00+00:00 Wont load textured models. <p>Two awd files exported from Maya.<br /> Cube with 2k texture.<br /> Cube without texture.</p> <p>The textured cube doesnt show. No errors given, no mesh loaded.<br /> Works fine in away.</p> <p>Win7 64</p> 2013-04-08T10:36:14+00:00 Md2 animation won’t show animation names that increment <p>Prefab has a animation display error when importing MD2 with animation names that increment. It confused with the frame number.</p> <p>I have 3 different idle animations for a model<br /> idle_0<br /> idle_1<br /> idle_2</p> <p>In the framelist it will look something like this.</p> <p>idle_0-000 -&gt; idle_0-088<br /> idle_1-000 -&gt; idle_1-120<br /> idle_2-000 -&gt; idle_3-052</p> <p>Will always comes out as Idle_.</p> <p>I tried a few different frame name deliminators and always get the same results</p> <p>idle_0-000 = idle_<br /> idle_0.000 = idle_<br /> idle-0_000 = idle-<br /> idle0000 = idle</p> <p>it will always get start at the first number.&nbsp; I tested it against the public old school MD2Viewer that is on the web.&nbsp; And the animation combination of any type works.&nbsp; It starts from the end of the string and finds the pattern.</p> <p>Thanks</p> 2013-02-28T03:51:12+00:00 Prefab3d/Maya Broken <p>Hey Guys,<br /> Not sure if it’s Maya or Prefab3d. But every time I export my 3D character from maya that has Skeleton Animation, when I open it in prefab3d the character’s animations start from the wrong part of their respective timelines. So strange!</p> <p><br /> I’m using Maya 2013 and Prefab3d 2.14</p> <p>Cheers,<br /> Peter Tucker</p> 2013-02-05T19:52:46+00:00 Problem exporting awd2 models from the new update Prefab 2.136 <p>Hi, since I installed Prefab2 new version (2.136), I can’t import awd2 models exported form this version. I explain it:<br /> When I import the old model, cube.awd (exported with the previous version of Prefab). The model is loaded successfully. <br /> But when I export the same model, wiht the new version . When I import it, wiht the same code of first; Flash fires this error:</p> <p>“TypeError: Error #1034: Error de conversión forzada: no se puede convertir away3d.core.base::Geometry@10d071791 en away3d.materials.MaterialBase.<br /> at Vector$object/<br /> at away3d.loaders.parsers::AWD2Parser/parseMeshInstance()[/Applications/Adobe Gaming SDK 1.0/Frameworks/Away3D/away3d-core-fp11_4_1_0_Alpha/src/away3d/loaders/parsers/]<br /> at away3d.loaders.parsers::AWD2Parser/parseNextBlock()[/Applications/Adobe Gaming SDK 1.0/Frameworks/Away3D/away3d-core-fp11_4_1_0_Alpha/src/away3d/loaders/parsers/]<br /> at away3d.loaders.parsers::AWD2Parser/proceedParsing()[/Applications/Adobe Gaming SDK 1.0/Frameworks/Away3D/away3d-core-fp11_4_1_0_Alpha/src/away3d/loaders/parsers/]<br /> at away3d.loaders.parsers::ParserBase/onInterval()[/Applications/Adobe Gaming SDK 1.0/Frameworks/Away3D/away3d-core-fp11_4_1_0_Alpha/src/away3d/loaders/parsers/]<br /> at flash.utils::Timer/_timerDispatch()<br /> at flash.utils::Timer/tick()”</p> <p>The models are exactly the same.</p> <p>Version of Away 3d: 4.1 Alpha<br /> Version of prefab: 2.136<br /> Os: Mac Osx mountain lion</p> <p>Thanks !!!</p> <p>&nbsp;</p> 2013-01-21T15:28:53+00:00 AWD2-Export v2.135 <p>Hey, after updating to v2.135 i get an BitmapTexture error when exporting awd2 of prefab and loading it in my project.<br /> The same .3ds file worked on previous version, when importing it into prefab and export as awd2.</p> <p>any idea?</p> 2013-01-17T10:27:41+00:00 Import .3ds wiht 2.131 <p>hey, after updating to 2.131 now my 3ds-imports are broken. all objects have wrong values in poisiton, rotation etc.<br /> i tried with excactly the same model, that work with 2.130.</p> <p>any ideas?</p> 2012-11-19T13:45:13+00:00 Specular and ambient color not saved <p>When you make changes to specular and ambient colours on materials they aren’t saved if you write out to a .awd file and read it back in.</p> 2012-12-12T11:25:14+00:00