update doesnt work for me

Software: Prefab3D

Manuel L., Member
Posted: 19 November 2012 10:25 AM   Total Posts: 99

hey the prefab update to 2.131 doesnt work for me ... always an error comes up that it wasnt successful. when i close prefab and try to run the setup manually its the same. i tried uninstall prefab, but this wasnt successful, too, because it didnt find setup.msi.
what can i do now?


Fabrice Closier, Administrator
Posted: 19 November 2012 11:47 AM   Total Posts: 1265   [ # 1 ]

if you were running Prefab and got the message that there is an update.
Prefab downloaded the update and wrote it on your desktop. You got the old AIR installer warning bug (installer damaged blabla, contact maker) while Prefab tried to install automatically.
Quit Prefab, run the installer that was installed on your desktop.

If however it still fails and as you say you cannot even uninstall Prefab, I guess something is wrong with your AIR runtime setup on your system. Download and install the latest AIR runtime from Adobe site and reinstall Prefab (with the Prefab installer on your desktop) .

If you run on Win8. I have no experience yet on this system and there might be AIR issues that I’m not aware of.


Manuel L., Member
Posted: 19 November 2012 01:40 PM   Total Posts: 99   [ # 2 ]

okay thank you, i will try it.
on my macbook it works.


Manuel L., Member
Posted: 16 January 2013 01:38 PM   Total Posts: 99   [ # 3 ]

hey i still cant get the latest version of prefab to work.

everytime i try, i get the error nr. 0.

i removed everything of prefab. then downloaded latest version from closier.nl.

double-click brings up the error.

what can i do now?

i installed the latest version of air, too :(


Manuel L., Member
Posted: 16 January 2013 02:42 PM   Total Posts: 99   [ # 4 ]

okay, now we got it.
the problem was in the windows regestry.
we had to clean up ALL entries with “prefab” in it and to delete all files of prefab on the harddisk.

thanks ^^


Fabrice Closier, Administrator
Posted: 16 January 2013 09:49 PM   Total Posts: 1265   [ # 5 ]

Glad you found the fix, I really wouldn’t have been able to help on this.
I’m mac based and test on Windows very little (when my daughter leave her laptop unwatched or bug win based friends when a win issue is reported)  wink
If you could provide me more details of what exactly was causing the problem, may be I could provide help to someone else if something similar would happend again or help me prevent do something that this OS doesn’t like.


Manuel L., Member
Posted: 17 January 2013 10:22 AM   Total Posts: 99   [ # 6 ]

well, i`m not sure what exactly was causing the problem, but i dont think that is has something to do with prefab but with windows or air.

i tried to update prefab, than there was the known error. i closed prefab i tried to install by using the downloaded prefab.air file. didnt work, too.
so i tried to uninstall prefab in system controls. didnt work, too. it said that it wasnt able to find setup.msi for uninstall at a temp-folder like “appData/local/temp/fla384” or something like that. i searched for this folder, but it didnt exist.

i deleted all prefab files on my harddisk and searched the windows registry for “prefab”.
i found many entries and deleted all of them. one entry held the value of this mysteric folder “appData/local/temp/fla384”. maybe deleting this entry was the solution, but i deleted all.

after that i was able to install the new prefab ^^



Away3D Forum

Member Login