Object disposed by an earlier call of dispose error on browser focus loss

Software: Away3D 4.x

Darcey, Moderator
Posted: 31 October 2011 09:07 AM   Total Posts: 209

Keep getting this randomly happening when the browser looses focus (chrome), the test app doesn’t error or use shadow or do anything complicated.

Error: Error #3694: The object was disposed by an earlier call of dispose() on it.
at flash.display3D::Context3D/clear()
at away3d.core.render::RendererBase/executeRender()[F:\wamp\www\Dev\Away3D Broomstick\Away3D4_Template\src\away3d\core\render\RendererBase.as:240]
at away3d.core.render::RendererBase/render()[F:\wamp\www\Dev\Away3D Broomstick\Away3D4_Template\src\away3d\core\render\RendererBase.as:218]
at away3d.lights.shadowmaps::DirectionalShadowMapper/drawDepthMap()[F:\wamp\www\Dev\Away3D Broomstick\Away3D4_Template\src\away3d\lights\shadowmaps\DirectionalShadowMapper.as:44]
at away3d.lights.shadowmaps::ShadowMapperBase/renderDepthMap()[F:\wamp\www\Dev\Away3D Broomstick\Away3D4_Template\src\away3d\lights\shadowmaps\ShadowMapperBase.as:103]
at away3d.containers::View3D/updateLights()[F:\wamp\www\Dev\Away3D Broomstick\Away3D4_Template\src\away3d\containers\View3D.as:524]
at away3d.containers::View3D/render()[F:\wamp\www\Dev\Away3D Broomstick\Away3D4_Template\src\away3d\containers\View3D.as:429]


zhiqiangxu, Newbie
Posted: 11 November 2011 11:18 AM   Total Posts: 20   [ # 1 ]

i have the same problem


Jerome Maurey-Delaunay, Moderator
Posted: 19 November 2011 10:03 PM   Total Posts: 17   [ # 2 ]


Got the same error on Windows (don’t remember if it was doing it on the mac) in the FB 4.6 every time I was closing the debug app.

I updated renderbase and added _context.enableErrorChecking = false; to the two occurrences where _context is set. It didn’t solve the issue, but at least I don’t get the errors anymore!

If I can’t see it, it doesn’t exist smile


Rima, Newbie
Posted: 13 March 2014 05:09 AM   Total Posts: 12   [ # 3 ]

i have the same error in windows ,when i run it in a browser page and then lock my (windows) machine and unlock it again.

Error: Error #3694: The object was disposed by an earlier call of dispose() on it.
at flash.display3D::Context3D/clear()
at away3d.core.render::RendererBase/executeRender()[D:\Workspace\3.6 Workspace\Waterdemo\src\away3d\core\render\RendererBase.as:240]
at away3d.core.render::RendererBase/render()[D:\Workspace\3.6 Workspace\Waterdemo\src\away3d\core\render\RendererBase.as:218]
at away3d.containers::View3D/render()[D:\Workspace\3.6 Workspace\Waterdemo\src\away3d\containers\View3D.as:440]
at DesktopWaterdemo/enterFrameHandler()[D:\Workspace\3.6 Workspace\Waterdemo\src\DesktopWaterdemo.as:821]

Does anyone know what the error is and how to avoid it?



Away3D Forum

Member Login