Software: Away3D 4.x

cph , Newbie
Posted: 13 April 2017 02:54 PM   Total Posts: 1

I currently have a successful implementation of the last Away3D source(4.x) using the Air SDK 23, but since the release of the Air SDK 24 and 25, I am unable to get Away3D to initialize at all. Does anyone have any suggestions?

Note: I am using stage3DManager and stage3DProxy too.


Fabrice Closier, Administrator
Posted: 13 April 2017 05:11 PM   Total Posts: 1265   [ # 1 ]

You do not provide any basic class/code to reproduce the problem… 
I run AIR and away3d without problems. So i’d say, start by checking your manifest.

make sure you have the correct version set
application xmlns=“”

and that your initial window has at least depthAndStencil to true and renderMode to direct.
Here an example that does work.


if it still not working, as said, provide a class to reproduce first. using view3D.


Kicker, Member
Posted: 02 May 2017 08:13 AM   Total Posts: 52   [ # 2 ]

I’ve just transitioned my entire project to Air SDK 25 and had absolutely no issue. I’m don’t think your problem comes from the SDK itself…



Away3D Forum

Member Login