Away3D Forum 0 Copyright (c) 2016 ExpressionEngine tag:away3d.com,2016:03:31 Material Attributes Not Saving tag:away3d.com,2016:forum/viewthread/.6076 2016-03-31T05:09:09Z 0 rustyk When trying to create a material using AwayBuilder, setting some attributes like Ambient or Specular level to 0 then saving, upon reloading you still get the default 1.0.

I’m using AwayBuilder 1.0 Gold, example scene attached.

]]>
No camera, no lights tag:away3d.com,2015:forum/viewthread/.5901 2015-07-06T14:04:42Z 2015-07-06T14:08:45Z movieclip I create plane, camera and light in Away Builder.
After loading AWD file in project, I have:

for (var i:int = 0; i < scene.numChildren; i++) { 
  var obj:* =  scene.getChildAt(i);

// depth, class, name, numChildren
trace (i, obj, obj.name, obj.numChildren);
}

traces:

0 [object ObjectContainer3D] DirectionalLight1 0
1 [object Mesh] Mesh1 0
2 [object ObjectContainer3D] Camera1 0

Camera and Light is empty containers and (obj as Camera3D) return null.

* yes, I see mesh, it correctly added to scene

]]>
Shadow Method set Null with one light in MultiPass crash the AwayBuilder tag:away3d.com,2014:forum/viewthread/.5269 2014-01-30T18:18:04Z 0 AlexisCuba Step:
1. Load a obj model or another type.
2. Set a new material. By default SinglePass is check.
3. Add new LightPicker.
4. Add a directional light to LightPicker and check Cath shadow.
5. Add a Shadow Method(Soft) to directional light.
6. Back to Material windows.
7. In material windows is default Shadow Light and Shadow Method to Null.
8. Now change SinglePass to MultiPass.
9. AwayBuilder don’t stop to show errors.

This work bad is the user don’t change Shadow Light.
Is I touch the Shadow Light and select Directional Light and back again to set Null, I can set MultiPass happy and safetly.

Some time if I forget that I lost all setting job.

Regards Alexis smile

]]>
LZMA bug? tag:away3d.com,2014:forum/viewthread/.5266 2014-01-29T11:18:52Z 2014-01-29T11:25:48Z Bolt Hello,

I’m testing some things with the Away Builder Live Tool, and when I save a model with LZMA compression enabled, it doesn’t save out the 4-byte uncompressed size at the beginning of the LZMA buffer.

This is different from the Away3D SDK C++, which does save out the 4-byte uncompressed size. Also, when I use the SDK to write a LZMA compressed file, and try to open it into the Away Builder Live Tool, I get an Error #1000, which locks up my browser.

Is this a bug with the Away Builder Live Tool?

Or has anything changed with the way LZMA files are written since the SDK was released?

Thanks

]]>
New SkeletonAnimationSet() without jointsPerVertex config panel? tag:away3d.com,2014:forum/viewthread/.5210 2014-01-04T01:36:34Z 0 bxc In the awaybuilder,if new SkeletonAnimationSet(),it seems jointsPerVertex will be 4.And we have nowhere to set the value.

]]>
skeleton animator timeline bug tag:away3d.com,2013:forum/viewthread/.4872 2013-08-23T00:03:11Z 0 Pierce When importing an md5anim the animation will “start” at a random time, meaning that when the timeline on the skeleton animator is set to zero, the animation will be set to begin at a random frame. Ideally animations should always start at frame 0, yes? Has anyone else noticed this?

]]>
RimLightMethod parameters tag:away3d.com,2013:forum/viewthread/.4824 2013-08-07T13:15:31Z 2013-08-07T13:16:28Z Ilya Aleshkov Away Builder doesn’t save properly RimLightMethod’s parameters.
“Power” field doesn’t affect stored power value.
Instead of this, value from “Strength” field rewrites power value.

To reproduce this bug just add RimLightMethod to any material.
Set strength to 0.35, for example, and leave power unchanged.
Save file and reopen it. Now check power value! It’s equal to strength!

Loading *.awd files in AS causes the same result. Maybe this problem occurs while loading.

]]>
Away Builder not saving geometry tag:away3d.com,2013:forum/viewthread/.4732 2013-07-15T01:19:10Z 0 fgauer In Away Builder

Create some VERY SIMPLE geometry:

1) Create a Sphere (Geometry)
2) Create a new Scene Object - Mesh - and use the Geometry created in step #1.
3) Save to a test.awd file

...now try to load this .awd file in Away3d. It uses the AWD2Parser but it dies because the geometry data is always null.

in away3d.loaders.parsers.AWD2Parser.as put a debug breakpoint at line 668. Check _blocks[3], this should contain the geometry data. It is always null.

If you attach a material/texture to the mesh, the texture save/loads from Away Builder into Away 3d, but the geometry is always null.

Bug with latest build? or am I doing something wrong?

]]>
Bugs!? tag:away3d.com,2013:forum/viewthread/.4708 2013-07-08T16:02:35Z 0 Jeff Ibacache Hi!, I have a few problems with AwayBuilder:

1 - When I manage my materials and then save the awd file, using the latest version of away3d, isn’t resolving the material correctly. In this case was a simple red lambert, but in the swf is showing me a white material.

2 - When I copy and paste some model on the editor and save the awd, the file save some material properties problems.

3 - Sometimes when I apply “effects” on the materials, this effects aren’t listed in the “effects list”

4 - I don’t know why when I save the awd file my textures goes low-quality denoting a lot of pixelation.

Any? :(

Cheers.

]]>
Installer doesn’t…install? tag:away3d.com,2013:forum/viewthread/.4703 2013-07-03T14:46:20Z 0 Ascanio Is it just me having problems installing the latest release 0.9.4?

I had AIR 3.7 beta. I removed it, restarted my computer and installed AIR 3.7 (stable).

Upon launching the .air installer of Away Builder 0.9.4 I get the following error (I’m translating it from Italian):

“An error occured.

It is not possible to install the application because the installation program is not configured correctly. Contact the author of the application to request support.”


I was trying to upgrade to 0.9.4 from 0.9.3 since I am having numerous problems (renaming elements requires me typing the names in the wordpad and then copy/pasting them to AB… and I am getting the error 1009 all the time now, I’ve tried exporting my mesh in any possible way, but AB simply doesn’t seem to like it… as soon as I try moving it inside a Container3D it crashes).

]]>